1
  1. I created a taxonomy vocabulary and terms.

enter image description here

  1. I created a content type with the taxonomy.

enter image description here

  1. I added contents.

enter image description here

  1. I would like to create a views block that will display all the taxonomy terms as links as well as each link should point to its NID.

enter image description here

For my views block:

I selected the taxonomy field.

I selected "Rendered taxonomy terms" in Formatter.

Click the Taxonomy field.

Selected output this field as link.

Entered node/[nid] as links path.

It did not work. Also, links are not pointed to NID. Can you please help how to edit the views settings?


Views settings: enter image description here

  • 2
    Why are you yelling at us? You think yelling makes me want to answer your question? – No Sssweat Jan 9 '17 at 22:54
  • 1
    Sorry for writing it in caps. I had a long day today. I simply lost my mind. I did edit my post. Hopefully, you will accept it this time. Thank you. – learn4ever Jan 9 '17 at 23:50
1

Assuming that the basis of your View is a node, you can add a field to your View: Content: Link (which is a link to the node of the View's row) and use the Rewrite results > Rewrite the output of this field with the contents of the taxonomy term (if I'm not mistaken [field_cities_we_serve1]).

  • I added views settings and the result above. Please advise if I followed your instruction correctly. Also, I am creating views block instead of views page. – learn4ever Jan 10 '17 at 0:42
  • @Drupol I only see the cities Are you u sure those nodes are tagged with the States? double check to make sure the term reference field is not empty, because they should be showing up. – No Sssweat Jan 10 '17 at 2:56
  • I made a mistake. I did not have nodes for states. Now, I added nodes for states and I have 6 nodes. I see them in this order on a column(VA, MD, cities....). How to group them by states? When I click link, it takes me to taxonomy/term/x. Instead, how to link to NID? – learn4ever Jan 10 '17 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.