0

I'm building a basic distribution and I cannot find any information on how contributed modules that are included in a distribution get placed into the drupal-root/profiles/profile-name/modules directory.

I've looked at a number of distributions, both hosted on drupal.org and not, trying to find some line(s) of code that does this, but there doesn't seem to be any. It has got to be happening "automatically" somehow, but it isn't working for me. When I add modules to my make file, they always end up in sites/all/modules.

I've spent hours trying to ask Google this question but every form I can come up with just gives me information on how to install a module, or how to move modules from the profile of a distribution into sites/all/modules - both of which I am well aware of...

So, can anyone direct me to documentation that can help me out? I'm sure it is out there, but I've hit a wall trying to find it.

4
  • I don't understand the question. When creating a distribution, you put the modules in the profiles folder yourself. That's how they get there.
    – Jaypan
    Jan 11, 2017 at 14:19
  • When I clone this --> github.com/jenitehan/tasty_backend, run make, cd to the new install directory and install Drupal, the modules are placed in profiles/tasty_backend/modules/{contrib,tasty_backend}. When I use the exact same syntax for my make files, contributed modules go in sites/all/modules/contrib. The code I'm working with is here --> github.com/dangxq42/xq42_d7_sk
    – dang42
    Jan 11, 2017 at 15:18
  • It's done by a script included with core (/scripts/build.sh). See drupal.org/node/642116 for full details
    – Clive
    Jan 11, 2017 at 15:24
  • @clive - I spent a couple hours looking at the info at the link you provided and following links from there, but I've still got no idea how to make this work. I'm clearly missing something, and I don't know what it is. There's no /scripts/build.sh in any download of core I grab using "drush dl drupal-7", so I don't know how to interpret what I read at your link.
    – dang42
    Jan 11, 2017 at 18:10

1 Answer 1

0

I found the problem.

I have two make files - drupal-org.make.yml & build-xq42_d7_sk.make.yml. I was including the following in the build-xq42_d7_sk.make.yml:

includes:
  - drupal-org.make.yml

Turns out this caused the problem. There's no need to include any reference to that file at all in the build-profile-name.make.yml file.

This is the first make file I've built and I created it by reading documentation and looking at existing make files for other projects. I saw this line in one of the make files I used as an example and assumed it was OK.

Now I know...!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.