0

I have a client Webform and I use a custom template for delivering the submissions to the Gmail inbox. I've set the sender's email to the component e-mail field.

The problem is that Gmail puts all the received emails into one thread as if though the sender is the same for all the emails. So it becomes impossible to manage the clients emails as everything is being mixed up.

Is it a Webform configuration or am I missing something?

0

This isn't really a Drupal question. Go to https://mail.google.com/mail/#settings/general and look at the Conversation View. This sets whether emails of the same topic are grouped together. So they aren't grouped together based on the from: address but on the title. Just set it to Conversation view off and save the settings.

Alternatively, make the subject of the mail unique. For example by adding the name or email address to it, or a unique key.

  • Once I set Conversation view off and try to reply, my message is not being displayed, and once I get another email from the same sender, it's being displayed as a separate email, in a separate thread. – Daniel Jan 12 '17 at 13:56
  • You could make the subject of the mail unique, for example by adding the name or email address to it. – Wim Mostrey Jan 12 '17 at 13:58
  • Will the following token: [submission:values:FIELDSET_FIELD_KEY:FIELD_KEY] work in the E-mail subject field ? – Daniel Jan 12 '17 at 14:03
  • Something like that, exactly. – Wim Mostrey Jan 12 '17 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.