3

I have a regular page set as the home page on my site. The Meta Tags, Title and Description are all set on the node, but do not show up on the home page.

Any ideas why?

  • 1
    Which meta tags module are you using? – Clive Feb 14 '12 at 20:07
3

Try printing

<?php print render($page['content']['metatags']); ?>

in your page.tpl.php or page--front.tpl.php if youre using Meta tags

2

If you are using the MetaTag module (https://www.drupal.org/project/metatag), then there are separate settings for the front page.

Go to /admin/config/search/metatags, and add the Global: Front Page settings.

1

One way to add metas to your home page is by downloading Meta tags quick and activating path-based metatags. Then, when logged as admin, click on the "Path-based metatags" tab.

0

Most meta tags modules put them in node pages only, eg, pages built around a single content type. So, they won't show up in views or other pages, like the front.

  • I'm not using a view for my front page. I have it pointed at an actual node. The node meta tags apply to every other page, but not the one I have designated as front. – Joren Feb 15 '12 at 0:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.