2

Simple rule:

after update node: create new entity with type: "comment"

but after update node, nothing happens...

why that?

UPD, added screenshots of my rule:

enter image description here

UPD2: i can create node by creating entity, but not a comment o_O

UPD3: ok understand what is the problem: i called the content type(machine name) 'task' =)

enter image description here

UPD4: errors while updating node and creating comment: enter image description here full error message: "Unable to get variable entity_created, it is not defined."

1 Answer 1

2

Because you did not save it.

Add action of Save Entity.

enter image description here

13
  • Thanks, but doesn't work -(
    – OnengLar
    Jan 19, 2017 at 0:57
  • 1
    @OnengLar you need to select Force saving immediately: True
    – No Sssweat
    Jan 19, 2017 at 1:04
  • yes, i have tried both
    – OnengLar
    Jan 19, 2017 at 1:06
  • @OnengLar should've worked. You sure you are testing/updating in the right content type (Task)?
    – No Sssweat
    Jan 19, 2017 at 1:07
  • 1
    @OnengLar feel free to login to my test site dg2kz.ply.st/node/1 User: OnengLar Pass: OnengLar as you can see it works. So perhaps you have some custom or some other contrib module that is causing your problem.
    – No Sssweat
    Jan 19, 2017 at 1:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.