0

I'm trying to get superfish accordion working on my pages. I have to have my jquery_update set to 1.9 or greater to get that function working.

But when I do I lose ckeditor on the comment fields for things like forums and such. I'm not sure what to do to resolve this problem.

Currently running Drupal 7.53

CKEditor for Drupal module 7.x-1.17

Superfish menu module 7.x-2.0

  • To improve your question, could you provide a link to the Drupal module or library you're using for the superfish accordion functionality, along with which version of Drupal you're using? – Wim Mostrey Jan 22 '17 at 17:11
  • According to the Superfish module documentation it only requires JQuery 1.6.1 or higher. Is there a specific reason you're using jQuery 1.8 or 1.9? – Wim Mostrey Jan 22 '17 at 17:17
  • The specific reason is that when I try to use any version lower then 1.9 the accordion display doesn't kick on on the smaller screen sizes. I'm not sure why, or how to fix it. – CW Smith Jan 22 '17 at 17:19
2

Okay, this may have been the cause.

I use AdaptiveTheme for my base theme on everything really. Right now the default theme makes use of a FooTheme created with a Corolla base. I had menu setting in the theme turned on and I think it was interfering with the Superfish menu.

If you are using Superfish then turn off all mobile menu options in AdaptiveTheme.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.