Hello I've just updated Drupal (to version 7.53) and now in Drush when I try launch the commands: "drush @theflyingeye.org up" (to update my website) or "drush @theflyingeye.org cc" (to clean chache) or "drush @theflyingeye.org dl view" (to download a basic module, view for example) I can just get this answer: "Unknown engine type outputformat"

If I digit:

"drush status" (after "su aegir")
I can get: 
"PHP configuration     :  /etc/php5/cli/php.ini                                 
 Drush version         :  5.10.0                                                
 Drush configuration   :  /var/aegir/.drush/drushrc.php                         
 Drush alias files     :  /var/aegir/.drush/server_master.alias.drushrc.php     
                          /var/aegir/.drush/theflyingeye.org.alias.drushrc.php  
                          /var/aegir/.drush/server_localhost.alias.drushrc.php  

Do you have any advise please to fix this problem?

  • Try clearing the drush cache. drush cc drush – Ruben Beekman Jan 25 '17 at 12:49
  • Also upgrading to Drush 8 could help ... see drush.org/en/master/install – Herman van Rink Jan 25 '17 at 14:02
  • Drush 5.10 is ancient so you should really, really upgrade. What does drush --debug version report? The "Unknown engine type outputformat" error indicates that you have another Drush around ... – hansfn Jan 25 '17 at 17:44
  • Sort of looks like you have a contrib module that has a Drush extension that is using a feature not available in Drush 5.10. Try upgrading as suggested by others. – greg_1_anderson Jan 26 '17 at 0:41
  • Hansfn, if I "drush --debug version" i get: Bootstrap to phase 0. [0 sec, 3.81 MB] Drush bootstrap phase : _drush_bootstrap_drush() [0 sec, 4.03 MB] Loading drushrc "/var/aegir/.drush/drushrc.php" into "home.drush" [bootstrap] scope. [0.02 sec, 4.04 MB] Cache HIT cid: 5.10.0-commandfiles-0-5ddf65b044b60bcd12160894847f471e [debug] [0.06 sec, 4.06 MB] Loading apache driver for the http service [0.27 sec, 10.77 MB] [notice] drush version 5.10.0 *** and some details *** – Gilles9999 Feb 8 '17 at 10:04

Start with upgrading to Drush 8 ... see http://drush.org/en/master/install

  • Thank you. I would like to specify the original installation is with AEGIR. Do you know if there is any special trick to update Drush through Aegir ? – Gilles9999 Feb 8 '17 at 10:06
  • The 'manual' upgrade script does it like this pretty much like the Drush docs suggest it. – Herman van Rink Feb 8 '17 at 13:48

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.