0

I've got a content type that has a link field in it. I added this link: ' https://wwwdev.ebi.ac.uk/interpro/' and saved. Then I realised this was an old address. It should have been 'https://www.ebi.ac.uk/interpro/' so I went back in, added the new address, and saved again. But the value didn't change! It was still showing 'https://wwwdev.ebi.ac.uk/interpro/'. Here's what I've done:

  • Flushed the Drupal caches
  • Flushed the browser cache
  • Tried in a new private/incognito window in another browser
  • Checked the database - it has the correct value, not the one showing on the page
  • Tried another url in the link field (like 'www.google.com') and that works fine
  • I put the correct address back in the field and it shows as the wrong address, even though the wrong address doesn't exist in the database.
  • Tried adding the correct address to the body field and it was transformed to the wrong address!
  • In 'Manage display' I tried the different settings for the link field. 'Domain as link' resulted in the right domain showing in the link text ('www.ebi.ac.uk') but with the link 'https://wwwdev.ebi.ac.uk/interpro/' in the href attribute.

Does anyone know what might be happening? I'm not using Conditional Fields, incidentally.

0

Okay, I fixed this. It was a legacy script in html.tpl.php. What I should have tried in my debugging was to switch theme. That would have at least narrowed it down to the theme layer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.