1

I am using Features that includes several basic site features such as the main menu and another custom navigation menu. Both are two level menus. I have included the menus in the Feature, but when I select the menu links, only a few of the menu link items are included in the selection list. The balance are missing.

What I have done:

  • I have searched for other issues on Drupal.org, but not found a similar one.
  • I have also examined the links and cannot find a difference between those that are included and those that are not.
  • I have flushed the menu cache.

Has anyone else seen anything like this or have any insights as to how I might fix this?

2 Answers 2

3

It could be an issue that can be fixed by UUIDs for Menu Links, opened for the UUID Features Integration module. In that issue, one of the project maintainers suggested the feature should instead be implemented in a separated project. UUID Features - Menu, a sandbox project, has been then created by ioskevich.

Something to be aware of: Menu links don't show up in the administrative UI, nor get added to the database, if they are not for existing nodes.

1
  • Thanks This link sounds correct. The additional menu items all shared the 'node/add' as there link while I am building views to accommodate the actual menu targets.
    – Ashlar
    Commented Feb 16, 2012 at 17:21
0

For future visitors, another possibility I found is link role filtering. I was trying to feature the User-menu | Log in menu-item which is filtered to only display for anonymous users. I verified there were no duplicates and tried uuid-menu-feature patch and it still would not show as an export option. However, once I disabled the anonymous role filtering it showed up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.