1

We've been using our Drupal webforms for years. Suddenly today, if an authorized user or the admin tries to download the results, the resulting file is 0bytes. The data is definitely there. I am unsure how to even troubleshoot this problem.

The really odd thing is that my dev site is a near identical copy of the live site and it works on the dev site (but the results are outdated). Whatever changed on the live site would have been in the last couple weeks and I can't think of what may have caused it that I wouldn't have implemented on the dev site first.

Drupal 7.50 Commons, webform 7.x-1.0. Let me know what other information would be helpful to provide, thanks!

Things I've Tried, to no avail:

  • downloaded the results into different formats
  • downloaded results as regular staff and admin user
  • downloaded only final and non-draft results
  • I'm not very familiar with webform, but there are a few things that I can advise you to do. 1. Make sure that it's updated to the latest supported version. Updating to a dev version could harm it. 2. Make sure that the permissions are enabled. 3. If that doesn't work you could research with these word in Google "drupal webform download empty" Hope that helps! – Chris Happy Jan 30 '17 at 22:10
1

I checked the permissions of the temporary files for our theme and sure enough, they were wrong. I am not sure what caused them to change, but they were set to root, whereas the dev site was set for www-data for both user and group. On our Debian server, Drupal uses the temporary files located at /tmp/example_theme.

To fix:

sudo chown -R www-data /var/example_theme

sudo chgrp -R www-data /var/example_theme

That fixed this and many other problems we were having today.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.