0

I'm using an exposed filter. When there is no result, where do I add "No results behavior" for the view?

7

On the view settings page, click on the Add button shown to the right of No results behavior. (The following screenshots are taken from the Taxonomy term view, but what described is valid for every view.)

screenshot

screenshot

In the dialog box that appears next, select Text area and click on the Apply (all displays) button at the bottom.

screenshot

The button name changes to Apply (this display) when This page (override) is selected for For on the top.

screenshot

In the Content text area that appears in the next dialog box, you can enter the text to show when no results are returned from the view.

screenshot

If you need it, you can also use some global tokens, listed under Available global token replacements.

screenshot

1

..............Have you tried here?

enter image description here

1

In the view settings, it's in the middle column, between Footer and pager.

The screenshot I am showing is for the front page view that comes with Drupal 8.

screenshot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.