1

For some reason I can no longer manage the display of a node in the backend. Managing the form display works but not the frontend display managing. I get the following error message:

Fatal error: Maximum execution time of 50 seconds exceeded in /customers/2/f/2/igghq.com/httpd.www/core/modules/field_ui/src/Element/FieldUiTable.php on line 100

I can still manage the display of other content types. Just not that specific one. Is there a way to reset the manage display backend form, maybee through the database?

  • running display suite
  • Drupal 8

More info: it only locks-up when loading the default display mode. Teaser still works

1

Wanted to post my solution(i encounter it too) if anyone stumble upon.

You don't have to uninstall and reinstall fieldgroup if you know which content type is causing this issue.

  • Go to Configuration Export ( [your URL]/admin/config/development/configuration/single/export)
  • Choose Entity View Display in Configuration type
  • Look for your content type in Configuration Name
  • Copy the configuration that appeared in Here is your configuration:
  • Open a text file and paste your config.
  • Look for field_group: , delete it together with it's child or until id
  • Then re-import your config.

That works for me without resetting other content type field groups.

| improve this answer | |
0

You will have to edit your php.ini for this. Open it and locate the max_execution_time setting. In your case, it will be set to 50. Update the setting to 300 for example (300 seconds = 5 minutes), save the file and restart Apache.

| improve this answer | |
  • Thanks for the reply man, but i don't have access to that file. Also any changes to .htaccess file will brick my site. My hosting doesn't allow that. That is why I'm asking if there is a way to change or reset the dispaly directly through the database. – jaypee Feb 4 '17 at 11:23
0

Another place you can update is settings.php file.

Simply try this -> edit sites/default/settings.php and added the following line:

ini_set('max_execution_time', 0);
| improve this answer | |
  • Again thank but no dice. The max execution time is still 50 s. No aswer to my first question maybee? How can I reset the display? That might fix it. Maybee there is a way to change the active layout. Or i could set all fields to be not visible? – jaypee Feb 4 '17 at 11:51
0

Do you have Page Manager enabled?

If you're using D7, Page Manger comes with C-tools module.

If you're using D8, you need to download it.

So enable the Page Manager module, and you should be able to manage them all from here.

| improve this answer | |
0

I've uninstalled and installed fieldgroups and that fixed it. I could access the default display of the content type again. Now I have to redo all my tabs but hey. I now know what killed it. I'll report back if i can find official confirmation of this issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.