2

I am using the AdvAgg module and all of its submodules, configured it using the configuration in AdvAgg README file.

After doing so, the site's mobile view got problem. So I disabled all from AdvAgg one by one to see what really caused the problem but haven't found one. Note that I was clearing my cache every time when I edited or did something. I then tried to totally uninstall eveything, including CSS and JS files from AdvAgg. But when I went to homepage there's no style at all. I checked the other pages but it looks normal to me. Also mobile view is back to normal.

I checked the source code for homepage and it is using an old CSS file which is produced by AdvAgg (sites/default/files/advagg_css/.css, which BTW is just a shortcut name for the css file since it is very long). That directory doesn't exist anymore since I already uninstalled AdvAgg. I enabled and configured AdvAgg again hoping everything will go back to normal but homepage still no style. My conclusion is homepage is loading in static mode.

Homepage was assigned to a certain page so I edited it but nothing's change in homepage. I decided to just copy the style from other pages, rename it to the one used by homepage and then upload it through ftp to the same location pointed by home's css.

Now, the site is back to normal but it is loading in static mode. How am I suppose to change it? Is there anything I've done wrong? I also have an error in status report regarding AdvAgg's HTTP request for js files not getting though. By the way, this is the site www.growplants.org. It is supposed to be the same with this page www.growplants.org/grow-plants as it is assigned to homepage.

  • What's "static mode" and how did you enable that? – Clive Feb 6 '17 at 14:42
  • @Clive I didn't enable it. It was like that I uninstalled AdvAgg. I don't know if "static mode" is the right term. It's like caching but I already cleared all my caches including browsers' so I think it's not about cache. And when I login and go to homepage I can't see any admin navigation at the top. I can see it with other pages except for homepage. It's like homepage is a separate file. – Ragnyl Romero Feb 6 '17 at 16:47
1

I was able to solved this problem by updating drupal core to latest version. If you were able to encounter problem like this and you have the latest version of drupal try to downgrade it to replace corrupted core files and update it again to latest version. I don't know what really caused the problem but this will solve the problem. Just run drush pm-update in your drush and it will update all modules and drupal core latest releases. If you only want to update drupal core run drush up drupal. If you want to downgrade drupal add the version drush up drupal-7.x.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.