4

I get this error after installing a module in modules/contrib and then uninstalling and moving it to a different directory. I accidentally installed the module in the wrong place.

This is in a local BLT/Drupal-VM environment. I've tried drush cr and rebuilding the drupal core directory as well as nuking the vendor folder that composer installs.

Seems that the paths to the installed modules gets stored in PHP memory some how and after the move php is not picking up the changes.

Restarting apache doesn't do anything either.

12

Restarting php from within the VM seems to have done the trick.

sudo service php5.6-fpm restart

  • Thanks for the answer. It did help me to solve the same issue. – Stephen.R Jan 17 '18 at 0:25
  • This did not work for me. – Kevin May 11 '18 at 19:36
  • 1
    Thanks, worked for me. I had to use " sudo /etc/init.d/php7.1-fpm restart" – oknate Sep 14 '18 at 14:58
  • Thanks, this have worked for me as well. PHP 7.2 "sudo /etc/init.d/php7.2-fpm restart" – marco-s Oct 10 '18 at 14:05
  • 2
    Did the trick for me as well, using Docksal I did fin restart cli. – Lester Peabody Jan 8 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.