2

On my Drupal 6 website, when I run manually cron, I get this error message.

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 4181580 bytes) in /dirname/includes/database.mysql-common.inc on line 34

Cron is set to automatically run every night; the last few days it wasn't running, so I tried it manually.

Where should I increase memory, in the settings.php file, in the php.ini file for PHP, or somewhere else? I'm using AWS RDS and EC2 instances.

I have this line in the settings.php file.

ini_set('memory_limit', '128M');
1

1 Answer 1

1

All you need to do is increase your PHP Memory Limit from 128M to 265M, for example adding the following line in the settings.php file.

ini_set('memory_limit', '256M')

For more information on other ways to change it, see Changing PHP memory limits.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.