1

I'm having trouble making some options appear as checkboxes in an exposed view form. The problem is that the "Allow multiple selection" option is not available in the filter. enter image description here

How can i make it visible. "Allow multiple selection" option.

0

You can go for Better Exposed Filters module.

The Better Exposed Filters module replaces the Views' default single- or multi-select boxes with radio buttons or checkboxes, respectively. Description fields and Select All/None links can be added to exposed filters to make for a better user experience.

| improve this answer | |
  • I installed BEF module also even that open is not coming. – jawahar j Feb 7 '17 at 9:58
  • Have you checked the BEF settings present in view advance section. – DRUPWAY Feb 7 '17 at 10:01
  • 1
    You have to change the "Exposed form style" under Advanced section and then in the Advanced > Exposed Form Style > settings exactly for the exposed filter you can select to use Display as "Checkboxes / Radio buttons" - checkboxes would be if the "Allow multiple selections" is checked (this time under Filter criteria > exact filter ) – Nikolay Borisov Feb 7 '17 at 10:07
  • Everything i selected in BEF settings but the problem is Allow multiple selections is not appearing in filter setting. – jawahar j Feb 7 '17 at 10:25
0

You Can use the Better Exposed Filters for the filters. Follow the Screenshots

enter image description here enter image description here enter image description here enter image description here

| improve this answer | |
  • I have done all the steps but still no changes – jawahar j Feb 7 '17 at 10:17
  • Have you checked the Allow Multiple selections option under the filtered field? – Karuna Feb 7 '17 at 10:19
  • Its coming fine in Content: Type (= Bank Blog) but i want that in Content: Blog Type (exposed) | Settings – jawahar j Feb 7 '17 at 10:20
  • What is blog type? Is it a content type? – Karuna Feb 7 '17 at 10:31
  • Yes blog type is my content type, – jawahar j Feb 7 '17 at 10:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.