1

I am using Acquia and Drush 8.1.8. I am following Acquia's instructions to load Drush extensions and aliases. My ~/.drush directory looks like this:

nickheiner@Nicks-MacBook-Pro.local:~/.drush  λ ls -l ~/.drush/
total 176
-rw-------@ 1 nickheiner  staff  43320 Feb  9 13:25 acapi.drush.php
drwxr-xr-x  6 nickheiner  staff    204 Feb  9 13:26 cache
-rw-------@ 1 nickheiner  staff   6026 Feb  9 13:14 cloudapi.acquia.com.pem
-rw-r--r--  1 nickheiner  staff   7741 Dec 19 16:52 drush.bashrc
-rw-r--r--  1 nickheiner  staff   1937 Dec 19 16:52 drush.complete.sh
-rw-r--r--  1 nickheiner  staff   2811 Dec 19 16:52 drush.prompt.sh
-rw-r--r--  1 nickheiner  staff  13628 Feb  9 13:19 drushrc.php
-rw-------@ 1 nickheiner  staff   1416 Feb  9 13:14 preview1.aliases.drushrc.php

However, Drush is not recognizing the commands:

λ ./drush cache-clear drush
'drush' cache was cleared.                                                [success]

λ ./drush help --filter=acapi
The specified command category acapi does not exist.                      [error]

I am also not seeing the alias:

λ ./drush sa
@none
@self
default

I tried opening up the permissions so they look like the following, but it did not solve the problem:

λ ls -la ~/.drush
total 176
drwxrwxrwx  10 nickheiner  staff    340 Feb 10 10:36 .
drwxr-xr-x+ 57 nickheiner  staff   1938 Feb 10 11:04 ..
-rwxrwxrwx@  1 nickheiner  staff  43320 Feb  9 13:12 acapi.drush.inc
drwxrwxrwx   6 nickheiner  staff    204 Feb  9 13:26 cache
-rwxrwxrwx@  1 nickheiner  staff   6026 Feb  9 13:12 cloudapi.acquia.com.pem
-rwxrwxrwx   1 nickheiner  staff   7741 Dec 19 16:52 drush.bashrc
-rwxrwxrwx   1 nickheiner  staff   1937 Dec 19 16:52 drush.complete.sh
-rwxrwxrwx   1 nickheiner  staff   2811 Dec 19 16:52 drush.prompt.sh
-rwxrwxrwx   1 nickheiner  staff  13628 Feb  9 13:19 drushrc.php
-rwxrwxrwx@  1 nickheiner  staff   1416 Feb  9 13:12 preview1.aliases.drushrc.php

What am I doing wrong?

  • Have you run drush cc drush? – Clive Feb 9 '17 at 18:49
  • Yes, I have run that command. – Nick Heiner Feb 10 '17 at 15:36
  • I suggest adding a link to "Acquia's instructions to load Drush extensions" so you can get help from everyone that uses Drush. I also recommend running drush status to see where Drush expects it's configuration. – hansfn Feb 10 '17 at 20:21
0

Can you confirm that you can see your acquia site aliases?

drush sa

I haven't done anything beyond the suggested tar -C $HOME -xf $HOME/Downloads/acquiacloud.tar.gz and drush help --filter=acapi shows all the commands.

  • I am not able to see the site aliases. – Nick Heiner Feb 10 '17 at 15:36
  • I think thats your problem. Would highly recommend you go through the steps here again: docs.acquia.com/cloud/drush-aliases Re download your aliases, extract them: tar -C $HOME -xf $HOME/Downloads/mysite.tar.gz Then try drush sa again – CliveCleaves Feb 11 '17 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.