1

On my laptop I recently moved my Drupal sites from Acquia Dev Desktop server to a standard MAMP setup. Problem is the root dir folder isn't being read. The root dir folder name would be, by default part of the base url. For example, the mission page URL should be http://localhost:8888/mywebsite/mission. But instead it's trying to load as http://localhost:8888/mission.

Since using Drupal I haven't had to once set a base url variable. In the settings.php file I found a variable for this which I uncommented and set. On line 282 in the settings file it now reads as like so:

$base_url = 'http://localhost:8888/mywebsite'; 

but this is having no effect whatsoever.

How or where can this be set? Or is there something I should do within the MAMP set up?

1

Use a virtual host in your webserver configuration with the DocumentRoot to your drupal installation:

<VirtualHost *:8888>
   DocumentRoot "/var/www/website"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.