0

I did implement the multilingual. I have successfully translated the content and interface in multiple languages. But when I try to use "/en" in URL for the English language which is the default. It does not work and shows me "404 Page" for default language only.

Can anyone please help me to fix it?

Thanks

0

I found the solution. Default language "English" requires the code to be enabled like the way when we add/change the code for new languages.

  1. Go to configuration click languages.
  2. Click "edit" for default language "English".
  3. Now put code language code "en" in "path prefix language code" text field."
  4. Save changes and access Url with/without "en" code. It will work in both cases for default language.

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.