0

On a Drupal Commerce Kickstart installation, I have created a subtheme of Omega Kickstart, following the process described here.

Subtheme is saved to: public_html/sites/all/new_theme

enter image description here

I kept only two of the *.css files for customization:

  • new_theme_style.css
  • new-theme-alpha-default.css

I updated the new_theme.info file as follows:

name = New Theme
package = Commerce Kickstart
core = 7.x
screenshot = screenshot.png
base theme = omega_kickstart 

No changes to the Regions / Theme Settings. Updates to the Optional Stylesheets: ; OPTIONAL STYLESHEETS

css[new_theme_style.css][name] = New theme global style.
css[new_theme_style.css][description] = This file holds all the globally active custom CSS of Monkey theme.
css[new_theme_style.css][options][weight] = 12
settings[alpha_css][new_theme_style.css] = 'new_theme_style.css'

Changes made in new-theme-alpha-default.css are working, but changes made to new_theme_style.css are not showing. When I use "Inspect element" tools, I see that global.css is called instead.

Is this an issue with the weight I am assigning here? I copied the css over from another subtheme that is working. I cannot pinpoint the problem...but know it is likely a noobie mistake.

Thx - keb

0

Turns out, I had everything set up correctly, but hadn't toggled "ON" the style sheet.

  1. Navigate to: Site settings >> Appearance >> Settings >> Toggle Styles
  2. Click "ON" checkbox next to New Theme global style. (all) - new_theme_style.css

I slept on it and woke early in the morning, remembering that not only do you need to enable your theme, you need to turn on the style sheet.

  • 1
    Sleep surely does help a lot of the times :) – undersound Feb 20 '17 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.