0

I've created a new view for admin/people; as part of the view set up, I've included "Path: /admin/people."

However, this causes a "page not found" error when I go to "admin/people/create"; I'm guessing I'm not supposed to use the path setting here.

How else would I override the default user view?

  • As a temporary solution I've created a template "page--admin--people.tpl.php" which uses a redirect if arg(2) == "create" this is obviously a really ugly way of doing it, but it is working. – jdu Feb 17 '12 at 19:22
4

Set your path to admin/people/list, not admin/people

Set the menu item for the page to "Default Menu Tab"

Set Default tab options to "Parent menu item already exists"

Worked for me, and didn't interfere with other items under the admin/people pages. It even added the "add user" link that normally appears on the regular admin/people pages.

|improve this answer|||||
1

It seems like you would have two somewhat clean options.

  • Alter the menu router that views defines so that it sets itself as a default tab and whatnot which is why I assume "create" is not working.
  • Use hook_menu_alter() to hide the default "admin/people" menu item (not delete, just change it to a callback so it doesn't show in menu) then define your view as "admin/people2" and just deal with the URL. You can also use the menu module to disable the link (or hook_menu_alter() I suppose as well)

Additionally you can look into hook_url_inbound_alter() and hook_url_outbound_alter() to try and fake the "people/create" or "people" pages.

|improve this answer|||||
0

I ran into this issue and for some reason, turning off the default view and using my overridden view with the same path got the same access denied (which oddly worked for all the other admin views). I disabled and enabled both default and my new view a bunch of times. I also edited the path and saved it a couple times. and it suddenly worked at some point. Not sure why, but it did. Hopefully that helps anyone else who finds this question.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.