2

We plan on updating our Drupal 6 (with MySQL 5.5x and PHP 5.x) site to Drupal 7.

Which version of PHP and MySQL should I choose?

1

You will get the best speed performance using PHP 7.x. I've been running a few Drupal sites on PHP 7 with no issues, and definite performance improvements over PHP 5.x.

MySQL 5.5 or 5.6 is good.

  • So upgrading from php 5.x to php 7 is simple? Also is php 7 now fully compatible with Drupal 7? – user3236765 Feb 26 '17 at 1:47
  • 1
    'Simple' is a relative term so I can't answer that's. Drupal core is compatible with PHP7. You may find some modules that throw some warnings however. For example the Backup and Migrate module throws some warnings, but it still works. As long as you have error reporting turned off you should be fine. – Jaypan Feb 26 '17 at 1:49
  • checkout Increase your Drupal 7 site speed with PHP 7 – No Sssweat Feb 26 '17 at 2:48
1

Before upgrading to Drupal 7, consider to directly upgrade to Drupal 8, as the upgrade path is smoother and D8 is the new version, so you won't have to migrate from D7 to D8 in a relatively short period.

Note this for Drupal 7, taken from Drupal PHP requirements:

Because PHP 7 is the newest release, extra care should still be taken with it. See the Drupal 7.50 release notes and the PHP 7 discussion for more details. However anecdotal evidence from a variety of users suggests that Drupal 7 can be successfully used on PHP 7, both before and after the 7.50 release.

Regarding MySQL, taken from Drupal database server requirements:

Drupal 7 supports MySQL 5.0.15/MySQL 5.1.30/MariaDB 5.1.44/Percona Server 5.1.70 or higher, and requires the PDO database extension for PHP

Anyway I invite you to read the two linked pages, as they contain useful information that goes beyond your question.

1

The minimum PHP version supported by Drupal 7 is 5.2.5. The minimum recommended PHP version for Drupal 7 is PHP 7.1.x, until December 1, 2019. After that date,PHP 7.1 will only receive security fixes, and it should not be anymore used for new sites.

  • Drupal 7.50's automated test suite is now fully passing on PHP 5.4, 5.5, 5.6, and 7; third-party modules could still have issues when running on PHP 7.1
  • Drupal 7.63 or higher is recommended for using PHP 7.1 and PHP 7.2
  • For Drupal 7.62 or higher, the minimum required is PHP 5.3.3

Drupal 7 supports MySQL 5.0.15/MySQL 5.1.30/MariaDB 5.1.44/Percona Server 5.1.70 or higher.

This is all for Drupal core. The compatibility with third-party modules can vary, and there could be modules having troubles with the newest PHP version, especially because backward incompatible changes.

Before upgrading PHP, you should make a test on a development site, and see if any of the modules you are using cause problems with the newer PHP/MySQL versions.

References

0

MySQL 5.5 will work just fine (according to the docs).

But as @user1527576 suggested, consider going from D6 directly to D8. Drupal's upgrade path usually skips (bunny hops?) major versions, unlike most software.

And with any Drupal upgrade, testing it is HIGHLY recommended - in a staging environment that resembles your production environment as closely as possible.

0

I think dont need to upgrade Mysql version. Drupal7 has support of Mysql5.0 and higher, but first you have to upgrade major version of Drupal6 and then can update to drupal7.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.