0

I am working on a D7 site with the latest stable version of Commerce and several Commerce Contrib modules. I recently applied the core 7.54 update from 7.53 and it appears to have caused several problems with my DC set up; specifically 1) the Store Admin UI; 2) Cart Shipping Calculations; 3) the addition of Coupons; 4) the system message list (particularly for cart actions doesn't clear, and builds up).

First, all of these symptoms seem to be related to 7.54 because I have the same code base (same module versions) on a test server without the issues.

Commerce Admin UI whatever is happening has broken part of the commerce store ui. I cannot add line items to an order (not coupons, not products, not shipping). When I select one of the line item options and click "add line item" the spinning icon appears but it stops. The same behavior occurs regardless of which line item type I choose. I can confirm that this functionality is preserved with 7.53. This seems to be caused by an ajax error "Invalid Form POST Data".

Commerce Shipping I have three commerce shipping services, two flat rate, one based on the Postal Code and Weight Module. When a user proceeds through the cart checkout process, the Shipping calculation is not performed and the user can proceed to payment without shipping charges being applied to the order. I receive the follow watchdog error: "Invalid POST data" from ajax referred by mysite.com/checkout/294/checkout. If the user were to go back to checkout page, the shipping charge is calculated.

Warning: Missing argument 1 for addressfield_default_values(), called in /home/phislub9/public_html/sites/all/modules/commerce_shipping_postal_code_weight/commerce_shipping_postal_code_weight.module on line 81 and defined in addressfield_default_values() (line 374 of /home/phislub9/public_html/sites/all/modules/addressfield/addressfield.module).
Warning: Missing argument 2 for addressfield_default_values(), called in /home/phislub9/public_html/sites/all/modules/commerce_shipping_postal_code_weight/commerce_shipping_postal_code_weight.module on line 81 and defined in addressfield_default_values() (line 374 of /home/phislub9/public_html/sites/all/modules/addressfield/addressfield.module).
Notice: Undefined variable: field in addressfield_default_values() (line 375 of /home/phislub9/public_html/sites/all/modules/addressfield/addressfield.module).
Notice: Undefined variable: instance in addressfield_default_values() (line 375 of /home/phislub9/public_html/sites/all/modules/addressfield/addressfield.module).
Notice: Undefined variable: instance in addressfield_default_values() (line 376 of /home/phislub9/public_html/sites/all/modules/addressfield/addressfield.module).
Notice: Undefined variable: field in addressfield_default_values() (line 408 of /home/phislub9/public_html/sites/all/modules/addressfield/addressfield.module).
Notice: Undefined variable: instance in addressfield_default_values() (line 409 of /home/phislub9/public_html/sites/all/modules/addressfield/addressfield.module).

I am led to believe that this is an issue with core version 7.54 because these errors don't occur on the 7.53 codebase.

Commerce Coupon Adding percentage based coupons also fails with the "Invalid Post Form Data" notification in watchdog. Coupons can be input but they are not applied when submitted. The form simply clears.

System Message Box Unclear if this is related, but the system message box also seems to be affected. The system message box keeps every cart action in the box, leading to a larger and larger box. This clears after flushing the cache as an admin, but users do not have this option and therefore cannot clear the message box. enter image description here

I'm not sure what else to add here, other than recently the server has been throwing PDO errors and crashing with the mysql server going away. It is a large codebase (over 100 modules).

UPDATE the module suggested in the comments here worked. Truncating the cache tables did not work.

  • nizz0k, not sure what the issue is here but can you please try few things for me. Remove drupal default caching and issue a command to repair cache_form table. Let me know how you go. – Ash U Mar 7 '17 at 5:26
  • Hi Ashish, do you mean the javascript and css caching? and is that command for drush? – nizz0k Mar 7 '17 at 5:35
  • Clear the full drupal cache using drupal admin UI or via drush (drush cc). Once that's done, try repairing cache_form table in database. – Ash U Mar 7 '17 at 5:56
  • The error normally occurs if the caching is enabled on Drupal site. You will need to disable caching (drupal.org/node/2598914), followed by clearing cache and repairing cache_form table. Once everything is resolved you can go back and enable caching again. – Ash U Mar 7 '17 at 6:00
  • Thanks, Ashish, I will have to look at this later this afternoon, but I've read the same thing regarding the problem but haven't found much in the way of a clear path to a solution. – nizz0k Mar 7 '17 at 6:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.