2

I'm running a local dev Drupal 8 install in Docker using the Docker4Drupal project. I tried to run drush up to update my core from Drupal 8.2.4 to Drupal 8.2.6 and got the following errors:

rmdir(/var/www/html/aadlorg/drupal-8.2.6/core/lib): Directory not empty filesystem.inc:150                [warning]
Destination directory /var/www/html/aadlorg/drupal-8.2.6 already exists.                                    [error]
Updating project drupal failed. Attempting to roll back to previously installed version.                    [error]
rmdir(/var/www/html/aadlorg/drupal-8.2.6/core/modules): Directory not empty filesystem.inc:150            [warning]
Destination directory /var/www/html/aadlorg/drupal-8.2.6 already exists.                                    [error]
Unable to move /home/www-data/drush-backups/drupal/20170303142739/drupal to                                 [error]
/var/www/html/aadlorg/drupal-8.2.6.
Could not restore backup and rollback from failed upgrade. You will need to resolve manually.               [error]
Backups were restored successfully.                                                                            [ok]
Backups were restored successfully.                                                                            [ok]
require_once(/var/www/html/aadlorg/core/includes/errors.inc): failed to open stream: No such file or      [warning]
directory bootstrap.inc:562
[03-Mar-2017 14:32:40 UTC] PHP Fatal error:  require_once(): Failed opening required '/var/www/html/aadlorg/core/includes/errors.inc' (include_path='.:') in /var/www/html/aadlorg/core/includes/bootstrap.inc on line 562
Fatal error: require_once(): Failed opening required '/var/www/html/aadlorg/core/includes/errors.inc' (include_path='.:') in /var/www/html/aadlorg/core/includes/bootstrap.inc on line 562
Drush command terminated abnormally due to an unrecoverable error.                                          [error]
Error: require_once(): Failed opening required '/var/www/html/aadlorg/core/includes/errors.inc'
(include_path='.:') in /var/www/html/aadlorg/core/includes/bootstrap.inc, line 562

Now my Drupal install is totally broken:

Warning: require_once(autoload.php): failed to open stream: No such file or directory in /var/www/html/aadlorg/index.php on line 14

Fatal error: require_once(): Failed opening required 'autoload.php' (include_path='.:') in /var/www/html/aadlorg/index.php on line 14

I'm logged into the container as the www-data user and all the directories are owned by that user. So did I do something wrong? Should I try to run drush as root? Just not use drush to update core?

1

Try using 2.0 version of docker4drupal, in the new version drush installed globally for www-data user to avoid potentials problems with permissions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.