0

My website is by default in French and I need to get an English version.

Prob n°1 : I've got this kind of Exposed filter (exported in a block), everything in it is translated excepted "Tri" (sort) and "Appliquer" (apply) which stay in french.

enter image description here

Here, you can see all modules about languages/i18n (add i18n, i18n_block)

enter image description here

In my exposed filter settings (in FR) :

enter image description here

In the view, translate view > English > traduire > and I wrote this

enter image description here

In Config > Regional > Translate I found what I wrote correctly

enter image description here

Answer n°1 : Why my exposed filter labels can't be translated ?

Answer n°2 : Another thing, it's maybe common but I found this strange, when I write a sentence in t() function, it must be in english and not in my site language else I get

enter image description here

Is it normal to write in english in t() function even if the site language is not ?

Thanks in advance for helps. I'm listening some tricks, advices and good practice about languages.

1

First, you need to select source/default language from admin/config/regional/language.

After you need to import .po file of English or your selected import other import languages (https://localize.drupal.org/translate/languages/en).

Now you will able to translate your term from Config > Regional > Translate. and those are visible according to your language.

  • French was still selected and put to default, and English enabled. I just import the file you said but nothing change about my exposed filters labels. – guish Mar 7 '17 at 9:45
  • did you import .po file? I have given you a link where you can download english.po file. and import it at admin/config/regional/translate/import – KrishaWeb Technologies Pvt Ltd Mar 7 '17 at 9:48
  • check this one i.stack.imgur.com/rt55v.jpg and enable it – KrishaWeb Technologies Pvt Ltd Mar 7 '17 at 9:50
  • Yes, I imported .po file. And my config is the same than yours (about your screen). In Config>Regional>Translate, all is good as earlier but exposed filters don't change... Something about imgur.com/1bONxM1 ? – guish Mar 7 '17 at 10:03
  • You need to go with the core and refresh language then again check translation is stay, if not then add again translate string after view front page. – KrishaWeb Technologies Pvt Ltd Mar 7 '17 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.