1

I have a Drupal 8 instance running on a Ubuntu 16.04 virtual machine through Apache2 to test with and learn Drupal.

Up until today, everything has worked correctly, but on starting my VM this morning the theme is no longer rendering and I can only see a bare HTML page which just seems to show the development toolbar.

None of the permissions on my Drupal directory have changed, nor has my Apache config, and I don't seem to recall any updates being run on the VM.

So far I have tried:

  • Restarting Apache
  • Restarting the VM
  • Restarting the host machine
  • Checked permissions of the Drupal installation
  • Changed to a different theme
  • Refreshed the page and cleared the cache
  • Cleared all caches through the Drupal UI

After changing to a different theme, those ones would render, but after changing back to the theme I want, it just shows the bare HTML again. The theme I'm wanting to use is Drupal 8 - Parallax and I haven't changed any of the HTML, CSS or Javascript for it.

What are the steps to troubleshoot this issue?


EDIT After further investigation, it seems to just be the "Home" page that isn't rendering properly. My other pages like FAQ, About Us, etc, are loading normally but the landing page of my site isn't displaying the theme when it was before. My Apache config for how I'm serving up the page is below.

<VirtualHost *:80>
        ServerName 192.168.1.239
        ServerAlias drupal-test.com

        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/drupal

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

The issue occurs when I go to drupal-test.com, drupal-test.com/node or the use the IP address of the server, which should take you to the front page of the site.

  • Did you try uninstalling all other themes and trying parallax that way? I've had the same issue than you with Parallax. Usually bugs with the css with a theme is caused by other themes installed (but not enabled by default) – Vasmir Mar 8 '17 at 9:37
  • Thanks, I'll give that a go. Do you just mean to uninstall through the UI, or manually on the server? – Donglecow Mar 8 '17 at 9:43
  • I've uninstalled all secondary themes now, leaving only Parallax and Bartik and the Seven administration themes installed with Parallax. I'm still having the issue. – Donglecow Mar 8 '17 at 9:58
  • Okay - I had another issue and eventually locked myself out of my site for a while! Now I've got access again, the theme seems to be rendering again. I've edited the OP to reflect the current situation as there are still other issues. – Donglecow Mar 8 '17 at 11:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.