1

I have encountered a problem with translation. When I try to translate a custom field of a custom node type it overwrites the original value.

Here is how it looks like

The custom field enter image description here

I create a node and enter following information

enter image description here

Then I click Save, the node appears, so far so good.

Next I click

enter image description here

I can see that translation not available now, click Add

enter image description here

Then I have the following url link

/node/8/translations/add/en/<my language>

Enter the following value

enter image description here

Now I have two nodes.

enter image description here

Let go to the original node and see what is the value of the field.

enter image description here

It is the same as it was before, but on the web page, I have two nodes with different translations.

The interesting thing that both of the two nodes in admin panel have the same translation as currently selected language, even if I click the edit button from the Translate tab, I need to switch the language via a switcher for example to get the content of a node for the selected language.

And that makes me crazy, I cannot understand what is going on really, how can I edit a translation of a node without changing the language ?

Please help me to solve this problem, I am completely lost with this stuff.

P.S.

Database entries are added correctly I guess

enter image description here

EDIT

My detection configuration before

enter image description here

And set it like this now

enter image description here

Logically, I guess the Interface Language should be responsible for translating Admin Panel interface and other helper popups that are used for the development purpose. But Content translation should be exactly what I am looking for, but when I switch off the Interface Detection and leave it to by default (uncheck session), but check Session in the Content translation section, my language switcher disappears.

  • Note: Your setup looks somewhat not so common, based on all the projects I've had so far. Usually the detection comes from the URL and then sometimes from the User preference. To be honest with you never tried the other settings. Could you try if setting it that way will help you solve your problem ? – O V Mar 13 '17 at 2:08
  • @OlegVidenov thanks I used default installation package and just installed language modules. I've also noticed that I am missing some options, what could be wrong ? I need to use session detection for the frontend part of the site, to save state in a user session – HelloMufecayo Mar 13 '17 at 13:18
1

I suggest looking and experimenting with the following settings:

admin/config/regional/language/detectionenter image description here

You can also check if the checkbox "Enable interface translation to English" is checked. That may cause this problem. admin/config/regional/language/edit/en enter image description here

Question : One thing didn't become clear for me: "It is the same as it was before, but on the web page, I have two nodes with different translations." - what is the url of the web page. Is it a page constructed with views, panels, or just node/nid ? Regards, Oleg

  • Thank for your help ! You only the one person who helped me a lot, I have updated my post please have a look. – HelloMufecayo Mar 12 '17 at 7:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.