I moved my site from HTTP to HTTPS, now a few days later my facebook likes are waaay lower.
For example one article under HTTP was 25K likes now under HTTPS it is 3K likes. I am face with the facebook likes count discrepancy and refer to this page to try to fix it. I removed the og:url content : [current-page:url:absolute] from the metatag config page and manually updated the og:url. I also removed the canonical URL [current-page:url:absolute] from the metatag as facebook is using it but facebook is still seeing the HTTPS likes not the HTTP likes for old content.
I also tried http://example.com[current-page:url:relative] without success.
Is there a way in metatag module to have the canonical URL to point to HTTP and not HTTPS by changing [current-page:url:absolute] for canonical URL?
How to make Facebook not see the 301 HTTP Redirect and stick to old url?

  • This is more or less a duplicate of stackoverflow.com/questions/27261781/…. I suppose setting og:url to http://example.com[current-page:url:relative] should be the way to, but apparently it takes some time befor facebook detects the change. – Neograph734 Mar 13 '17 at 22:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.