1

I know this question was asked so many times but I read all the answers and I didn't find any solution working for me, so I'm looking for help. I have done the following to try resolve it:

  1. Checked if the site address is set up properly
  2. Downloaded the SMTP module

    • Configured the module to my Gmail account
    • I was getting the unable to send email error here unless I checked the "Send mail by queue box (I am not sure what this does, but the error message disappeared.)
    • When I send a test email to my Gmail address I'm not getting it (I checked spam and it's not there)
  3. I have then moved on and downloaded the phpmailer library and extracted it into my sites/all/libraries folder (I even tried putting it in the smtp folder as I read about that somewhere) but still not working

    • I configured the phpmailer with my smtp module and when I tried to send a test email from phpmailer I'm not receiving that either.
  4. I checked emails are sent when a user registers or forgets the password, and emails aren't sent in those cases either. Drupal is not sending out emails.

  5. I then moved on to check my logs and all the attempts are in red:

enter image description here

I am new to Drupal; I am not sure what they mean.

Is there anything else I can try?

This is just a test site so I have it on my localhost.

When I click on the error this is the information that is showing:

enter image description here

  • I tried doing this but it says I need to be an administrator to see this option. I don't understand how I am not the administrator. – user3353335 Mar 17 '17 at 12:28
  • It would be wise to blank your email adress in the screenshot. perhaps only mention the error message. – undersound Mar 17 '17 at 12:32
  • I am not very familliar with this module but here are a few suggestions - What happens when you enable debugging at Admin - Configuration - SMTP Authentication Support (admin/config/system/smtp)? Do you see any useful responses from the server? In the README of the module it says you don't need to install the php library anymore as it is included in the module. Do you seen any error at the status page at admin/reports/status? – undersound Mar 17 '17 at 13:17
  • 2
    Have you checked if you can send email from the CLI (using Unix mail or some similar tool)? – Free Radical Mar 17 '17 at 13:31
  • Did you enable SSL in Smpt config? – Vasmir Mar 17 '17 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.