0

My goal is to have three front page versions per language. Browser language detection is enabled. Front page is correctly rendered with a language according to Accept-Language, but there is no language indicator in URL, example: host.com/it.

Have I missed something in configuration or I have to do this feature (redirect) programmatically (or Rules) ?

2

You have to use the language detection method "URL" for this. When using other detection methods the language prefix is not used.

Even then a URL without a language prefix still works and uses the default "Selected Language" at the end of the detection methods list or another method you have enabled between those two.

If you want that the homepage is redirected to the language prefixed URL instead, use the module Redirect and set this option:

GLOBAL REDIRECTS

[x] Enforce clean and canonical URLs.

Enabling this will automatically redirect to the canonical URL of any page. That includes redirecting to an alias if existing, removing trainling slashes, ensure the language prefix is set and similar clean-up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.