0

I had to import a multisite (Drupal 7) to Acquia dev desktop. The import seemed to be successful. But the following error is displayed when the page is accessed:

PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'kanu_backup.semaphore' doesn't exist: ...

What should I do?

0

Have you tried running your update.php file?

(https://www.drupal.org/upgrade/running-update-php)

II. Run update.php In your web browser navigate to the directory where Drupal is installed:

http://www.example.com/update.php

or

http://www.example.com/test_site/update.php (if you are upgrading a test site) The update script should only be run once. It will complete all the updates at once. If prompted for which version, choose the closest starting version that makes sense for you.

This will update the default Drupal and contributed module database tables automatically (versions prior to 4.7 will require manual upgrade of the contributed modules). Once the script has stopped loading, be sure to scroll to the bottom to look for errors.

| improve this answer | |
  • update.php produces another error: PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'drupal_kanu.system' doesn't exist: SELECT name, schema_version FROM {system} WHERE type = :type; Array ( [:type] => module ) in drupal_get_installed_schema_version() (line 155 of /Volumes/ Mac HD 2/Daten Frank/Dokumente/Website-Projekte/devdesktop/Drupal_01/includes/install.inc). – Frank Giesecke Mar 22 '17 at 17:52
  • it seems that the default prefix "main_" is ignored by. The tables are existing, with the default prefix "main_" – Frank Giesecke Mar 22 '17 at 17:57
  • all prefixes are ignored. I erased them , one site is after update running. That is not multisite. it's only my backup of D7 before upgrade to D8 (another provider too...) – Frank Giesecke Mar 22 '17 at 18:07
  • Try to clear cache with drush. – developer Mar 23 '17 at 4:46
  • That was to the problem. Profiles were ignored: main_ and shared_. After renaming the tables everything was OK. – Frank Giesecke Mar 23 '17 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.