1

I am trying to follow this document to enable clean urls on a fresh Drupal installation. When I run the test, I get:

The clean URL test failed. 

My host provider confirms that mod_rewrite is enabled. I am using a shared server.

In my Drupal installation folder, I see a hidden .htaccess.txt file. Apparently, it has been installed by Drupal itself.

But, I cannot find information in the document mentioned above explaining to solve this issue. What is missing to make Clean URLs work? Thanks.

7

The file name should just be .htaccess, without the .txt extension.

3

Follow the link.Am guessing that you are using drupal 7.Check the reply by doncheks. http://drupal.org/node/1572984#comment-6751806

  • 2
    Welcome to Drupal Answers. Normally, link-only answers aren't considered good ones here. You can keep the link, but you should really provide a summary. – mpdonadio Nov 19 '12 at 22:47
2

setting the correct RewriteBase inside files/default/setting.php fixes it for my virtual host (=typical with reseller hosting accounts):

  # Modify the RewriteBase if you are using Drupal in a subdirectory or in a
  # VirtualDocumentRoot and the rewrite rules are not working properly.
  # For example if your site is at http://example.com/drupal uncomment and
  # modify the following line:
  # RewriteBase /drupal
  #
  # If your site is running in a VirtualDocumentRoot at http://example.com/,
  # uncomment the following line:
RewriteBase /~planet/v3
1

I believe I had a similar problem as you when I set up my first Drupal site. If you scroll down on this page, I believe it was the same fix as the user 'alessandro oliviero' mentions. I had to change one line of the .htaccess file and I do believe it was the line with "RewriteRule" on it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.