1

We are running a drupal 7 multi-site installation within a (windows based) cloud service. We have drush 8.1.10 installed via composer.

For the update process, I want to be able to use drush @sites commmands.

When I type drush site-alias, I get the list of the sites folder.

When I type drush @sites status, I don't get asked about whether I want to perform this on all sites, but I just get this result:

Drupal version         :  7.54                                              
PHP configuration      :  "D:\Program Files (x86)\PHP\v5.6\php.ini"         
PHP OS                 :  WINNT                                             
Drush script           :  D:/home/site/wwwroot/vendor/drush/drush/drush.php 
Drush version          :  8.1.10                                            
Drush temp directory   :  D:\local\Temp                                     
Drush configuration    :                                                    
Drush alias files      :                                                    
Drupal root            :  D:\home\site\wwwroot                              
Drupal Settings File   :  MISSING                                           

Performing the same actions with the same version of our code, drupal and drush, I get a prompt which asks me to verify that I want to see the status for every site.

Now the really strange part: When I do something like drush -l <site-that-gets-listed-by-drush-site-alias> status, I get a complete status of that specific site.

Does someone have an idea on how to get the @sites command to work?

Best regards!

P.S.:

Here is a run with debug information. Probably, this could help. I just skipped some of the scanning for aliases, which repeats all the time with the same output.

PS D:\home\site\wwwroot> .\vendor\bin\drush @sites -y status -vvvd
Drush preflight prepare loaded autoloader at                         [preflight]
D:\home\site\wwwroot\vendor\autoload.php [0.13 sec, 259.63 KB]
Starting Drush preflight. [0.13 sec, 260.4 KB]                       [preflight]
Cache HIT cid: 8.1.10-commandfiles-0-f748c6d1836d748deace0564c5218dd5    [debug]
[0.25 sec, 310.74 KB]
Scanning into D:\local\ProgramData/Drush/etc/drush for                   [debug]
/.*aliases\.drush(8|)rc\.php$/ [0.84 sec, 443.22 KB]
[...]
Bootstrap to phase 0. [1.93 sec, 2.02 MB]                            [bootstrap]
Trying to bootstrap as far as we can. [1.94 sec, 2.03 MB]                [debug]
Drush bootstrap phase : bootstrap_drupal_root() [1.98 sec, 2.04 MB]  [bootstrap]
Initialized Drupal 7.54 root directory at D:\home\site\wwwroot [2.06 [bootstrap]
sec, 2.04 MB]
Find command files for phase 1 (max=7) [2.07 sec, 745.23 KB]             [debug]
Cache HIT cid: 8.1.10-commandfiles-1-33dfe6ed0539b2c2a8675cb53eeeaf96    [debug]
[2.07 sec, 747.7 KB]
Cache HIT cid:                                                           [debug]
8.1.10-annotationfiles-1-61fb1c32cc67adeb9a2dbb1e2fad1453 [2.07 sec, 748.05 KB]
Scanning into D:\local\ProgramData/Drush/etc/drush for                   [debug]
/.*aliases\.drush(8|)rc\.php$/ [2.07 sec, 751 KB]
[...]
Bootstrap phase bootstrap_drupal_site() failed to validate;              [debug]
continuing at bootstrap_drupal_root(). [2.39 sec, 770.21 KB]
Found command: core-status (commandfile=core) [2.39 sec, 770.28 KB]  [bootstrap]
Loading outputformat engine. [2.57 sec, 2.09 MB]                        [notice]
Calling hook drush_core_status [2.68 sec, 2.17 MB]                       [debug]
Scanning into D:\local\ProgramData/Drush/etc/drush for                   [debug]
/.*aliases\.drush(8|)rc\.php$/ [2.68 sec, 2.18 MB]
[...]
Returned from hook drush_core_status [2.99 sec, 2.19 MB]                 [debug]
 Drupal version         :  7.54                                              
 PHP configuration      :  "D:\Program Files (x86)\PHP\v5.6\php.ini"         
 PHP OS                 :  WINNT                                             
 Drush script           :  D:/home/site/wwwroot/vendor/drush/drush/drush.php 
 Drush version          :  8.1.10                                            
 Drush temp directory   :  D:\local\Temp                                     
 Drush configuration    :                                                    
 Drush alias files      :                                                    
 Drupal root            :  D:\home\site\wwwroot                              
 Drupal Settings File   :  MISSING                                           

Command dispatch complete [3.09 sec, 2.19 MB]                           [notice]
  • When I perform a drush -l <site> pm-update -vvvd, it connects to the database and shows me all the tables (no matter what prefix), but afterwards messages like this: "D:/home/site/wwwroot\\vendor\\bin/\\drush.launcher" --backend=2 [notice] --verbose --debug --root=D:/home/site/wwwroot --uri=<path> pm-updatestatus 2>&1 [49.85 sec, 7.48 MB] pm-updatestatus failed. [50.5 sec, 7.47 MB] [31;40m[1m[error][0m – floneo Mar 23 '17 at 14:20
  • The debug output mentions that drush tries to check wget --version and curl --version. It doesn't tell, that it fails, but when I type the commands into the powershell, they fail. Does this help? – floneo Mar 23 '17 at 15:36
  • You wrote "Performing the same actions with the same version of our code, drupal and drush, I get a prompt [...]". I feel something is missing in that sentence. Anyway, I think you should compare the debug output of a drush status command that works and the drush @sites status command that doesn't work. – hansfn Apr 3 '17 at 7:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.