1

I've created a multilingual drupal page (English as default and german). On the english page the title works correctly, but on the german page the title is still Drupal (I changed it in the settings and it works in my browser tab header)

How can I make it work?

supermew

3
  • did you try to rebuild the cache ? ( clear cache)
    – Yuseferi
    Mar 25, 2017 at 21:49
  • Are you talking about the sitename? If so, did you try to translate it at admin/config/system/site-information/translate/de/add?
    – berliner
    Mar 26, 2017 at 1:25
  • Haha, it was the cache :D
    – user74180
    Mar 27, 2017 at 20:37

1 Answer 1

0

Here are a few pointers which might help:

  • If you are talking about the name of your site, then please use the Admin > Configuration > System > Site information page to configure it - once in English and once in German.
  • If you are talking about a page node you created, then:
    • Make sure that you enable translations for the title property from content translation settings.
    • Make sure you use the Translate tab on the node to input the German title for your page.
  • Having done everything above, if you still do not see the German title on the German version of your page, try clearing cache from the Configuration > Development > Performance page.

References:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.