I have a pretty minimal Drupal 8 install with some views blocks that show upcoming event node links. I've noticed that once an event is passed they still show up and it is because the pages of my site are cached. However, I set the "Page cache maximum age" on the performance page to 6 hours and Drupal continually caches pages for days or weeks. I have to manually click clear all caches before the site will update. Cron is also setup and running regularly without a problem. I thought maybe that triggered the cache rebuild but I've set it to 6 hours, 12 hours, 3 hours, etc. with no result.

I'm not sure why this is happening. I'm not doing anything else to cache, no other modules or server programs like Varnish or anything.

1 Answer 1


The Internal Page Cache for anonymous users doesn't use any configuration option. If you want a quick solution in UI your only chance is to de-install this module.

Better for performance is to set an expiration time for the cached pages, but for this you need custom code, see this answer Anonymous user cache control.

In both cases the setting on the performance page is still necessary to set the correct headers for external caches.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.