0

I have a website with 4 languages, while English is the default. Each language has its own directory (mydomain.com/contact, mydomain.com/jp/contact, etc.). I have the following languages:

  • English
  • Czech
  • Japanese
  • Russian

For the record, my language detection is configured with these priorities:

  1. URL
  2. Session
  3. Selected Language
  4. Browser

When I try to edit a translation of a content page (let's say Japanese), it works just fine, but when I try to open an edit page (mydomain.com/node/6/edit) of the orignal, english node, I'm always getting "Edit Basic Page Nobg Kontakty [Czech translation]", with the Czech content and can't access the edit page for the english original. What to do?

1

If you want to use English as default without URL prefix you have to disable

  • Session
  • Browser

in the language detection list, so that only URL and Selected Language (which can't be removed) is enabled.

Then configure in

  • Selected Language

the site's default language (English).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.