2

I have installed Drupal 7 on a local computer on stack called Denwer (similar to WAMP) and Windows 7; I see that all pages load without Overlay module (it is on, on modules page). I guess that jQuery does not work at all: Views slideshow doesn't work, when I add node all parameters load in a list instead of paging-listing mode.

I cleared all caches, reinstalled Drupal 7 using the development snapshot, clean-installed Denwer: all this doesn't work.

I remember I didn't have such problems on Windows XP.

  • Did you try adding, for example, "#overlay=admin/appearance" to an URL and see what happens. I sometimes noticed the overlay is not show, but the theme I set as administrative theme is used for the setting page. – kiamlaluno Apr 14 '11 at 14:08
2

Have you seen Overlay and jQuery dont work on Win 7, but work on XP?

The last comment reported in that report is the following one:

Problem resolved. I still don't know why this problem arise, but after Windows 7 latest updates installed (on 18 apr 2011) overlay and jquery now working.

1

I noticed I had the exact same problem when I made the mistake of installing a test site in a folder with a space in the name; as soon as I went back and corrected the problem (so the URL did not contain any %20 character) the problem was resolved.

1

Check your URL.

The ovelay is enabled by URL in this way: http://localhost/yoursite/#overlay=admin/appearance; if you write http://localhost/yoursite/admin/appearance the overlay is "disabled".

Also check if the you have the "access overlay" permission in order to see the administrative pages on the overlay.

  • Thanks for answer, but i tried this too. - no matter. I only see front page of the site and no any overlay at all. I am superadmin, and have permission to Overlay. – Vic Nicethemer Apr 14 '11 at 12:04
0

I couldn't get the overlay to work as well after I upgraded Drupal 7 to a newer version. Issue turned out to be some changes I had made to .htaccess. Reverted back to the original .htaccess, and the overlays appeared again.

This was with Server 2003, IIS 6.5 (I think?).

0

I had the same problem with Drupal 8, if you are using WAMP than go to apache modules, and enable rewrite_module it solved the problem for me right away!

I figured the problem was there because kiamlaluno said (in this post) that is't a URL issue...

Hope this works for whoever googles this problem in the future

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.