2

I'm trying to install drupal console latest release candidate globally via composer. I run

$ composer global require drupal/console:~1.0.0@rc

But I get the following error:

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - drupal/console 1.0.0-rc9 requires drupal/console-core ~1.0 -> satisfiable by drupal/console-core[1.0.0-rc1, 1.0.0-rc10, 1.0.0-rc11, 1.0.0-rc12, 1.0.0-rc13, 1.0.0-rc14, 1.0.0-rc15, 1.0.0-rc16, 1.0.0-rc2, 1.0.0-rc3, 1.0.0-rc4, 1.0.0-rc5, 1.0.0-rc6, 1.0.0-rc7, 1.0.0-rc9, v1.0.0-rc8] but these conflict with your requirements or minimum-stability.
    - drupal/console 1.0.0-rc8 requires drupal/console-core ^1.0 -> satisfiable by drupal/console-core[1.0.0-rc1, 1.0.0-rc10, 1.0.0-rc11, 1.0.0-rc12, 1.0.0-rc13, 1.0.0-rc14, 1.0.0-rc15, 1.0.0-rc16, 1.0.0-rc2, 1.0.0-rc3, 1.0.0-rc4, 1.0.0-rc5, 1.0.0-rc6, 1.0.0-rc7, 1.0.0-rc9, v1.0.0-rc8] but these conflict with your requirements or minimum-stability.
    - drupal/console 1.0.0-rc7 requires drupal/console-core ^1.0 -> satisfiable by drupal/console-core[1.0.0-rc1, 1.0.0-rc10, 1.0.0-rc11, 1.0.0-rc12, 1.0.0-rc13, 1.0.0-rc14, 1.0.0-rc15, 1.0.0-rc16, 1.0.0-rc2, 1.0.0-rc3, 1.0.0-rc4, 1.0.0-rc5, 1.0.0-rc6, 1.0.0-rc7, 1.0.0-rc9, v1.0.0-rc8] but these conflict with your requirements or minimum-stability.
    - drupal/console 1.0.0-rc6 requires drupal/console-core ^1.0 -> satisfiable by drupal/console-core[1.0.0-rc1, 1.0.0-rc10, 1.0.0-rc11, 1.0.0-rc12, 1.0.0-rc13, 1.0.0-rc14, 1.0.0-rc15, 1.0.0-rc16, 1.0.0-rc2, 1.0.0-rc3, 1.0.0-rc4, 1.0.0-rc5, 1.0.0-rc6, 1.0.0-rc7, 1.0.0-rc9, v1.0.0-rc8] but these conflict with your requirements or minimum-stability.
    - drupal/console 1.0.0-rc5 requires drupal/console-core ^1.0 -> satisfiable by drupal/console-core[1.0.0-rc1, 1.0.0-rc10, 1.0.0-rc11, 1.0.0-rc12, 1.0.0-rc13, 1.0.0-rc14, 1.0.0-rc15, 1.0.0-rc16, 1.0.0-rc2, 1.0.0-rc3, 1.0.0-rc4, 1.0.0-rc5, 1.0.0-rc6, 1.0.0-rc7, 1.0.0-rc9, v1.0.0-rc8] but these conflict with your requirements or minimum-stability.
    - drupal/console 1.0.0-rc4 requires drupal/console-core ^1.0 -> satisfiable by drupal/console-core[1.0.0-rc1, 1.0.0-rc10, 1.0.0-rc11, 1.0.0-rc12, 1.0.0-rc13, 1.0.0-rc14, 1.0.0-rc15, 1.0.0-rc16, 1.0.0-rc2, 1.0.0-rc3, 1.0.0-rc4, 1.0.0-rc5, 1.0.0-rc6, 1.0.0-rc7, 1.0.0-rc9, v1.0.0-rc8] but these conflict with your requirements or minimum-stability.
    - drupal/console 1.0.0-rc3 requires drupal/console-core ^1.0@RC -> satisfiable by drupal/console-core[1.0.0-rc1, 1.0.0-rc10, 1.0.0-rc11, 1.0.0-rc12, 1.0.0-rc13, 1.0.0-rc14, 1.0.0-rc15, 1.0.0-rc16, 1.0.0-rc2, 1.0.0-rc3, 1.0.0-rc4, 1.0.0-rc5, 1.0.0-rc6, 1.0.0-rc7, 1.0.0-rc9, v1.0.0-rc8] but these conflict with your requirements or minimum-stability.
    - drupal/console 1.0.0-rc2 requires drupal/console-core ^1.0@RC -> satisfiable by drupal/console-core[1.0.0-rc1, 1.0.0-rc10, 1.0.0-rc11, 1.0.0-rc12, 1.0.0-rc13, 1.0.0-rc14, 1.0.0-rc15, 1.0.0-rc16, 1.0.0-rc2, 1.0.0-rc3, 1.0.0-rc4, 1.0.0-rc5, 1.0.0-rc6, 1.0.0-rc7, 1.0.0-rc9, v1.0.0-rc8] but these conflict with your requirements or minimum-stability.
    - drupal/console 1.0.0-rc16 requires drupal/console-core 1.0.0-rc16 -> satisfiable by drupal/console-core[1.0.0-rc16] but these conflict with your requirements or minimum-stability.
    - drupal/console 1.0.0-rc15 requires drupal/console-core 1.0.0-rc15 -> satisfiable by drupal/console-core[1.0.0-rc15] but these conflict with your requirements or minimum-stability.
    - drupal/console 1.0.0-rc14 requires drupal/console-core 1.0.0-rc14 -> satisfiable by drupal/console-core[1.0.0-rc14] but these conflict with your requirements or minimum-stability.
    - drupal/console 1.0.0-rc13 requires drupal/console-core 1.0.0-rc13 -> satisfiable by drupal/console-core[1.0.0-rc13] but these conflict with your requirements or minimum-stability.
    - drupal/console 1.0.0-rc12 requires drupal/console-core 1.0.0-rc12 -> satisfiable by drupal/console-core[1.0.0-rc12] but these conflict with your requirements or minimum-stability.
    - drupal/console 1.0.0-rc11 requires drupal/console-core ~1.0 -> satisfiable by drupal/console-core[1.0.0-rc1, 1.0.0-rc10, 1.0.0-rc11, 1.0.0-rc12, 1.0.0-rc13, 1.0.0-rc14, 1.0.0-rc15, 1.0.0-rc16, 1.0.0-rc2, 1.0.0-rc3, 1.0.0-rc4, 1.0.0-rc5, 1.0.0-rc6, 1.0.0-rc7, 1.0.0-rc9, v1.0.0-rc8] but these conflict with your requirements or minimum-stability.
    - drupal/console 1.0.0-rc10 requires drupal/console-core ~1.0 -> satisfiable by drupal/console-core[1.0.0-rc1, 1.0.0-rc10, 1.0.0-rc11, 1.0.0-rc12, 1.0.0-rc13, 1.0.0-rc14, 1.0.0-rc15, 1.0.0-rc16, 1.0.0-rc2, 1.0.0-rc3, 1.0.0-rc4, 1.0.0-rc5, 1.0.0-rc6, 1.0.0-rc7, 1.0.0-rc9, v1.0.0-rc8] but these conflict with your requirements or minimum-stability.
    - drupal/console 1.0.0-rc1 requires drupal/console-core ~1.0 -> satisfiable by drupal/console-core[1.0.0-rc1, 1.0.0-rc10, 1.0.0-rc11, 1.0.0-rc12, 1.0.0-rc13, 1.0.0-rc14, 1.0.0-rc15, 1.0.0-rc16, 1.0.0-rc2, 1.0.0-rc3, 1.0.0-rc4, 1.0.0-rc5, 1.0.0-rc6, 1.0.0-rc7, 1.0.0-rc9, v1.0.0-rc8] but these conflict with your requirements or minimum-stability.
    - Removal request for drupal/console == 1.0.0.0-beta5
    - Installation request for drupal/console ~1.0.0@rc -> satisfiable by drupal/console[1.0.0-rc1, 1.0.0-rc10, 1.0.0-rc11, 1.0.0-rc12, 1.0.0-rc13, 1.0.0-rc14, 1.0.0-rc15, 1.0.0-rc16, 1.0.0-rc2, 1.0.0-rc3, 1.0.0-rc4, 1.0.0-rc5, 1.0.0-rc6, 1.0.0-rc7, 1.0.0-rc8, 1.0.0-rc9, 1.0.0-beta5].


Installation failed, reverting ./composer.json to its original content.

When I run:

$ composer global require drupal/console:~1.0.0@dev

It installs beta5.

P.S. I don't want to edit composer.json, it will be an automated script

2

So the problem was that Drupal console's dependent packages (drupal/console-core, drupal/console-en) didn't use the minimum-stability option that I specified via @, so I just had to set it globally and run again:

$ composer global config minimum-stability rc
$ composer global require drupal/console:1.*

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.