2

I have recently disables, uninstalled and removed a few modules from my drupal 7 site but this error keeps popping up no matter what I do, I have researched how to remove them but to my dismay nothing, please help.

User warning: The following module is missing from the file system: admin. For information about how to fix this, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /opt/lampp/htdocs/drupal/includes/bootstrap.inc).

1

Most probably the disabling and uninstalling process of the modules didn't went smoothly. According to this help page on Drupal.org:

Restore the module and actually disable and uninstall it (recommended if possible): First, restore the module to its original location in the file system. Then either go to the Modules page and disable/uninstall it from there, or use Drush (drush dis module_name && drush pm-uninstall module_name, where module_name should be replaced with the name of the module).

Don't forget to also clear the caches, that "magic" feature also resolves a lot of problems ;)

You could also disable the specific message by using the Disable Messages module. However, I would recommend to try cleaning up your Drupal configuration that are causing the messages.

  • I cleared the cash and did all the uninstalling correctly. The problem was most likely caused because I transferred some of the modules from a friends PC to mine but in the long run I think it can be ignored so the disable messages module helped. Thank you, Watergate. – JavaJunior Apr 3 '17 at 8:33
  • Good to hear you have solved your problem. – Watergate Apr 3 '17 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.