0

How to install Social Auth LinkedIn PHP Library with composer for Open Social Drupal module ?

I try to install Open Social (https://www.drupal.org/project/social) but I can't because I can find how to install the LinkedIn library with Composer.

I already installed successfully Google, Facebook and Twitter library with Composer.

"Social Auth LinkedIn module requirements Not installed Social Auth LinkedIn requires LinkedIn PHP Library. Make sure the library is installed via Composer."

Thanks.

2 Answers 2

1

According to the composer.json of that module, you need happyr/linkedin-api-client. So to install that with Composer, from the root of your Drupal project run:

composer require happyr/linkedin-api-client:1.0.0

Since that library has dependencies too, you probably need to install them too. Basing on the documentation, you could need to execute the following too.

composer require php-http/guzzle6-adapter
composer require guzzlehttp/psr7 php-http/message
6
  • Your requirements could not be resolved to an installable set of packages. - happyr/linkedin-api-client 1.1.x-dev requires php-http/client-implementation ^1.0 -> no matching package found. - happyr/linkedin-api-client 1.0.0 requires php-http/client-implementation ^1.0 -> no matching package found. - Installation request for happyr/linkedin-api-client ^1.0 -> satisfiable by happyr/linkedin-api-client[1.0.0, 1.1.x-dev]. Apr 3, 2017 at 13:39
  • What happens if you just use 1.0.0 instead?
    – Kevin
    Apr 3, 2017 at 13:42
  • Problem 1 - Installation request for happyr/linkedin-api-client 1.0.0 -> satisfiable by happyr/linkedin-api-client[1.0.0]. - happyr/linkedin-api-client 1.0.0 requires php-http/client-implementation ^1.0 -> no matching package found. Apr 3, 2017 at 13:43
  • Potential causes: - A typo in the package name - The package is not available in a stable-enough version according to your minimum-stability setting see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details. Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems. Apr 3, 2017 at 13:45
  • Check the GitHub page for that package. It looks like it has prerequisites to installing it: github.com/Happyr/LinkedIn-API-client
    – Kevin
    Apr 3, 2017 at 13:45
0

I installed

composer require php-http/guzzle6-adapter
composer require guzzlehttp/psr7 php-http/message

and then installed

composer require happyr/linkedin-api-client:1.0.0

and it worked

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.