4

I have enabled ckeditor module its effecting all the textarea fields with summary and input format. How can I exclude ckeditor for some fields?

3

The problem you experienced with configuring the field is that in core there is no option to select the allowed text formats. When this module is installed

https://www.drupal.org/project/allowed_formats

you can select the text format that is available for a specific field and then you can choose in the settings of the text format whether to use ckeditor or not.

There is work going on to put this in core: https://www.drupal.org/node/784672

2

Using form alter I have tried to set the field type to textarea but it was throwing error. As an alternative to that I have made

$form['body']['widget'][0]['#format'] = 'plain_text';

Its working for me.

-2

If you are using CK editor then go to

/admin/settings/ckeditor/edit/Default

to change the setting for the default profile, under visibility settings select include and enter the text aread ids for which you want the editor to be enabled.

And as the blog help says entering

blog@.edit-body - matches all fields of type "blog" called edit-body, on any page. node/add/.edit-user-* - matches fields starting with "edit-user-" on pages starting with "node/add/

  • I was asking for Drupal 8 – Sri Harsha Apr 4 '17 at 5:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.