0

not very familiar with composer yet

I run composer update on a dev version (thank GOD) but from 8.2.6 drupal was updated to 8.3.0 but some functionality was broken due to the upgrade ... how can I safely run composer update and not upgrade to latest drupal ... or is there some other command I should run instead ?

I understand that I probably have to change the composer.json to do it but I don't quite know what it is that it I need to include in it

Any help would be appeciated

this doc article don't quite explain such a thing

UPDATE

I run the command from eyal composer require drupal/drupal:8.2.* but creates problem and site was unusable after that (received 500 error)

giorgos@glaptop:~/websites/domain.com$ composer require drupal/drupal:8.2.*
./composer.json has been updated
No patches supplied.
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 1 install, 0 updates, 0 removals
No patches supplied.
Gathering patches for dependencies. This might take a minute.
  - Installing drupal/drupal (dev-8.2.x 2125663)  Cloning 2125663da0 from cache
Writing lock file
Generating autoload files

Installation failed, reverting ./composer.json to its original content.


  [RuntimeException]                                                                                               
  Could not scan for classes inside "docroot/core/lib/Drupal.php" which does not appear to be a file nor a folder  


require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...

I had to run composer update and now with the 8.3.1 version of drupal the composer update run smoothly. I just needed to run drush up rules-8.x-3.x-dev after that since there was a problem with rules and 8.3.1

EDIT Anyone knows why my question received -2 ? (was I downvoted ? what is the reason ?)

  • 3
    Run composer require drupal/drupal:8.2.* this would instruct composer to only install minor versions of drupal. – Eyal Apr 6 '17 at 19:23
  • This is great thanks ... I will accept this as the right asnwer if you post it ... – GiorgosK Apr 7 '17 at 5:47
1

It depends on the version you specify in the composer.json file. You can specify broad versioning, or exact version, and composer will adhere to that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.