0

I'm trying desperately to update a customer's e-commerce site. I am a novice in Drupal.

Drupal version: 7.18
Drush version: 8.1.10 
Install profile: commerce_kickstart 

I checked with Drush for security updates:

drush up --security-only

 Name                                           Installed Version  Proposed version  Message                   
 Drupal                                         7.18               7.54              SECURITY UPDATE available 
 Views Bulk Operations (views_bulk_operations)  7.x-3.1            7.x-3.4           SECURITY UPDATE available 
 Address Field Tokens (addressfield_tokens)     7.x-1.3            7.x-1.5           SECURITY UPDATE available 
 Chaos tools (ctools)                           7.x-1.2            7.x-1.12          SECURITY UPDATE available 
 CKEditor (ckeditor)                            7.x-1.12           7.x-1.17          SECURITY UPDATE available 
 Commerce (commerce)                            7.x-1.4            7.x-1.13          SECURITY UPDATE available 
 Commerce Kickstart (commerce_kickstart)        7.x-2.0            7.x-2.45          SECURITY UPDATE available 
 Ogone (commerce_ogone)                         7.x-1.3            7.x-1.6           SECURITY UPDATE available 
 Context (context)                              7.x-3.0-beta6      7.x-3.7           SECURITY UPDATE available 
 Date (date)                                    7.x-2.6            7.x-2.10          SECURITY UPDATE available 
 Display Suite (ds)                             7.x-2.0            7.x-2.14          SECURITY UPDATE available 
 Entity API (entity)                            7.x-1.0-rc3        7.x-1.8           SECURITY UPDATE available 
 Entity Reference (entityreference)             7.x-1.0            7.x-1.2           SECURITY UPDATE available 
 Features (features)                            7.x-1.0            7.x-2.10          SECURITY UPDATE available 
 Fieldgroup (field_group)                       7.x-1.1            7.x-1.5           SECURITY UPDATE available 
 Media (media)                                  7.x-1.2            7.x-1.6           SECURITY UPDATE available 
 Google Analytics (google_analytics)            7.x-1.3            7.x-2.3           SECURITY UPDATE available 
 Internationalization (i18n)                    7.x-1.7+14-dev     7.x-1.15          SECURITY UPDATE available 
 Inline Entity Form (inline_entity_form)        7.x-1.0            7.x-1.8           SECURITY UPDATE available 
 jQuery Update (jquery_update)                  7.x-2.3            7.x-2.7           SECURITY UPDATE available 
 LoginToboggan (logintoboggan)                  7.x-1.3            7.x-1.5           SECURITY UPDATE available 
 MailChimp (mailchimp)                          7.x-2.10           7.x-4.8           SECURITY UPDATE available 
 Meta tags (metatag)                            7.x-1.0-beta5      7.x-1.21          SECURITY UPDATE available 
 Meta tags (quick) (metatags_quick)             7.x-2.7            7.x-2.9           SECURITY UPDATE available 
 Migrate (migrate)                              7.x-2.5            7.x-2.8           SECURITY UPDATE available 
 Mime Mail (mimemail)                           7.x-1.0-alpha2     7.x-1.0-beta4     SECURITY UPDATE available 
 OAuth (oauth)                                  7.x-3.0+18-dev     7.x-3.4           SECURITY UPDATE available 
 Services (services)                            7.x-3.3            7.x-3.19          SECURITY UPDATE available 
 Rules (rules)                                  7.x-2.2            7.x-2.9           SECURITY UPDATE available 
 Search API (search_api)                        7.x-1.4            7.x-1.21          SECURITY UPDATE available 
 Search sorts (search_api_sorts)                7.x-1.3            7.x-1.7           SECURITY UPDATE available 
 Title (title)                                  7.x-1.0-alpha5     7.x-1.0-alpha9    SECURITY UPDATE available 
 Views (views)                                  7.x-3.14           7.x-3.16          SECURITY UPDATE available 
 Views Data Export (views_data_export)          7.x-3.0-beta9      7.x-3.2           SECURITY UPDATE available 
 Views megarow (views_megarow)                  7.x-1.0            7.x-1.7           SECURITY UPDATE available

Of course the update in drush does not work absolutely. I get an error even when performing module backups drush:

The date directory could not be found within the modules directory at                                                         [error]
/xxxx/profiles/commerce_kickstart/modules/contrib/date, perhaps the project is enabled but has
been deleted from disk.

I tried as asked a commerce_kickstart update manually by downloading the commerce_kickstart-7.x-2.45 core. I deleted on my server all Drupal folders and files with the exception of the sites/ folder Then, I copied all the folders and files with the exception of the folder commerce_kickstart-7.x-2.45 core sites on my server. I tried to access the update.php url and I get a lot of userWarning directly!

User warning: The following module is missing from the file system: commerce_discount_date. For information about how to fix this, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).
User warning: The following module is missing from the file system: commerce_kickstart_payment. For information about how to fix this, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).
User warning: The following module is missing from the file system: commerce_kickstart_service_provider. For information about how to fix this, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).
User warning: The following module is missing from the file system: jirafe. For information about how to fix this, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).
User warning: The following theme has moved within the file system: shiny. In order to fix this, clear caches or put the theme back in its original location. For more information, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).
User warning: The following module is missing from the file system: commerce_kickstart_checkout_redirect. For information about how to fix this, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).
User warning: The following module is missing from the file system: imagcache_actions. For information about how to fix this, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).
User warning: The following theme has moved within the file system: alpha. In order to fix this, clear caches or put the theme back in its original location. For more information, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).
User warning: The following theme has moved within the file system: omega. In order to fix this, clear caches or put the theme back in its original location. For more information, see the documentation page. in _drupal_trigger_error_with_delayed_logging() (line 1138 of /xxx/includes/bootstrap.inc).

I also try to reinstall these modules as suggested documentation => impossible with drush always errors, even no way to make a clear cache either.

I still tried to update the 84 pendings updates => ERROR

An AJAX HTTP error occurred. HTTP Result Code: 200 Debugging information follows. update.php?op=selection&token=tLbdNHx9Y0AFjTKaNYc_NuAif0VkT_HPsfb6pIS7f8Q&id=42504&op=do StatusText: OK ResponseText: Fatal error: Call to undefined function inline_conditions_get_info() in /xxx/profiles/commerce_kickstart/modules/contrib/commerce_discount/commerce_discount.rules.inc on line 12

And here is the content of the error page:

DatabaseSchemaObjectExistsException: Table field_data_commerce_compatibility_strategy already exists. in DatabaseSchema->createTable() (line 660 of /xxx/includes/database/schema.inc).

What I also had by trying the update with Drush from commerce_kickstart !!!

Someone would have an idea because I find no information on the Internet ???

  • 7.18, really? Are you familiar with what 7.32 was about? – Pierre.Vriens Apr 11 '17 at 13:14
  • 1
    I believe you have to upgrade using the distribution, and not using vanilla methods like downloading the tarball or drush certain modules. drupalcommerce.org/commerce-kickstart-2/install – Kevin Apr 11 '17 at 13:27
  • Also, if you ever had modules and uninstalled/deleted the folders, after Drupal 7.50 I believe you will see those warnings about missing modules. You will need to get another module to clean up the system table: drupal.org/project/module_missing_message_fixer – Kevin Apr 11 '17 at 13:29
  • Hi Kevin, i also use the module missing_message_fixer before to do the update, but I had only 3 modules to fix. I fixed but i always after copy file and launch update.php a lot of user warning .... Any idea how to upgrade this commerce_kickstart ??? – Michaël Thiébault Apr 12 '17 at 14:06
  • @MichaëlThiébault I just placed a bid on your project. – No Sssweat May 19 '17 at 23:06
0

It's advised that you do not use the typical Drush workflow, nor updating individual modules. The first step is to review our documentation, which highlights upgrading, https://drupalcommerce.org/commerce-kickstart-2/install.

The first step that I recommend is getting the Features Override module to capture your customizations. Enable this module and create a feature containing all of your changes to the base of CK2. We have test coveraging asserting that this works from upgrading from even Features 1.x to the 2.x upgrade.

The most important thing to remember is that a distribution should be treated like updating Drupal core. It will replace everything but the following

  • sites/all
  • sites/default
  • I download an old version of feature override: features_override-7.x-1.x-dev because i have an old version of Feature. After that in the create Feature form, in the Edit components drop-down selector I don't have "Features Overrides" ??? I don't find documentation and in the documentation of drupalcommerce.org/commerce-kickstart-2/install website the links not working ! A new paradigm for overriding Drupal Features Features and Overrides – Part Deux ... The doc says that upgrade drupal kickstart is easier but i think it's not true... Please any Help ? – Michaël Thiébault May 9 '17 at 9:19
0

Hi you've dug yourself into a hole. To start with the original system was a distribution, someone has gone an removed the modus from the modules profile folder and put it in the sites/all/modules folder . They have either have the module in the tow pleases or have deleted it from one location an placed it in the other. That was you initial issue which wasn't that problematic to resolve.

Now you've gone an done a number of more dramatic changes which are mode complex to resolve.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.