1

I am getting this error when trying to run pm-list. I am in the Drupal folder, not at the root, on Mamp Pro on my Mac using OS X El Capitan. I have tried setting the host from localhost to 127.0.0.1, tried adding paths to the .bash_profile. Not sure what else to do. Following is the output upon entering pm-list:

The drush command 'pm-list' could not be executed.                 
Drush was not able to start (bootstrap) the Drupal database.        
Hint: This may occur when Drush is trying to:
 * bootstrap a site that has not been installed or does not have a
configured database. In this case you can select another site with a
working database setup by specifying the URI to use with the --uri
parameter on the command line. See `drush topic docs-aliases` for
details.
 * connect the database through a socket. The socket file may be
wrong or the php-cli may have no access to it in a jailed shell. See
http://drupal.org/node/1428638 for details.

Drush was attempting to connect to:
 Drupal version         :  7.43
 Site URI               :  http://default
 Database driver        :  mysql
 Database hostname      :  127.0.0.1
 Database port          :
 Database username      :  interdev
 Database name          :  interdev
 PHP executable         :  /usr/local/bin/php
 PHP configuration      :  /usr/local/etc/php/7.0/php.ini
 PHP OS                 :  Darwin
 Drush script           :  /Users/studio17/Sites/interdev/vendor/dr
                       ush/drush/drush.php
 Drush version          :  8.1.11
 Drush temp directory   :  /tmp
 Drush configuration    :
 Drush alias files      :
 Drupal root            :  /Users/studio17/Sites/interdev
 Drupal Settings File   :  sites/default/settings.php
 Site path              :  sites/default

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.