I accidentally deleted the Markdown filter module from the file system while it was still enabled. So I installed it again, via the GUI.

Now I cannot load the module uninstall page - it says "The website encountered an unexpected error. Please try again later", and the message in the log says Drupal\Component\Plugin\Exception\PluginNotFoundException: The "markdown" plugin does not exist. in Drupal\Core\Plugin\DefaultPluginManager->doGetDefinition()

I have cleared caches, run cron, deleted sites/default/files/php ... all to no avail.

Any ideas?

Edit: I have just tried to enable the module again, and got this message: Unable to install Markdown filter, markdown.settings already exists in active configuration. I looked through the config and cache_config tables and cannot find this setting.

  • Try adding it manually in core.extension config, e.g. with drush or a single config export and import. Apparently the module was forcibly removed there without being uninstalled properly.
    – Berdir
    Apr 30, 2017 at 18:48
  • Thanks Berdir. Any way to do that without shell access? I only have sftp.
    – naomi
    Apr 30, 2017 at 22:55
  • Single config export and import can be done in the UI but the core.extension file might be excluded from that, as it's pretty special. You can do a full config export, download that as an archive in the UI, the extract it, change the file, upload it into the configured config sync folder (usually sites/default/files/config_SOMEHASH/sync) and then go to config sync to import it.
    – Berdir
    May 1, 2017 at 8:14
  • I tried to do this using the import/export config GUI ( since it was not core.extension but markdown.settings that I needed to delete). However after exporting, extracting, deleting the file and then recompressing & importing, it said "Your file is uploaded and ready to import" but nothing showed on the sync tab. I fixed it in the DB, see my answer,
    – naomi
    May 2, 2017 at 9:04

1 Answer 1


It turned out there was a markdown.settings entry in the database (in the config or cache_config table, I forget which). I deleted this row and then it was possible to install and then uninstall the module.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.