2

I've created a view that filters content based on the tags I associate with each page. It works great when my tags are single words.

In this case, posts containing any one of the above tags appear on my page.

However, I want to create and select tags for posts that contain multiple words (e.g. movie titles) such as Eternal Sunshine of the Spotless Mind, Garden State, The Aviator.

Currently, I apply tags via checkboxes (in case that's relevant), not using the autocomplete.

When I do this, the views filter only displays content containing the FIRST tag. For example, Only content using the Eternal Sunshine of the Spotless Mind tag is displayed, but content containing the other two tags is absent.

Any idea why this might be? Are my tags just too long? If so, how can I get around this? The following are the contextual filter settings.

screenshot

2

I found Only works with first taxonomy term views3 D7 which is about the same issue you have.

This is what comment #18 and #20 say. You might also look at comment #28.

This works very well, but it only works with the first tag/taxonomy term applied to a node. For instance, if a post was tagged Cheese, Recipe, Tomatoes, and Pasta, it would show other posts tagged with Cheese, but not those tagged with Recipe, Tomatoes, or Pasta. Is there a way to get it to consider all taxonomy terms, not just the first one?

I just tried this solution and it seems to work. Just select "Reduce Duplicates" then under "More" select "Allow multiple values." That's it, you should have all the things being printed out and not just things related to the first term. Let me know if this helps.

1
  • You are awesome, thank you SO much. Worked like a charm. – Brittany May 1 '17 at 19:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.