1

I installed Views Data Export module on a Drupal 7.50 site and it works beautifully. I am trying to incorporate it now into a new website (which happens to be 7.54). I have cleared all the Drupal caches as well as the browser cache and have checked that the module is enabled. I also have Views Excel Export extension installed and enabled on both sites.

I'm completely stumped that this works perfectly on one site and not working on another.First site, data export is a display option. Second site it is not an option.

Update: I thought I checked the versions, as I installed them on the same day, but somehow, the one on the site that works is an older version (3.1 vs. 3.2).

I tried uninstalling it and installing the older version but it didn't resolve the issue. I also checked permissions but there aren't permissions for this module.

Here is the conversation on Drupal.org with no resolution.

2

I had installed the Views Excel Export module first. I had to uninstall both modules and then reinstall them in the correct order: Views data export first and then Views Excel Export. This solved the issue for me!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.