0

enter image description here

enter image description here

while creating my custom theme i am getting a error "This theme is missing a 'content' region.".please have a look on screen attached(designed by manoj kumar).any help would be appricated.

1
  • Thanks rjl your suggestion is correct. – Manoj Paul Aug 13 '20 at 10:39
2

Looks like you need to indent your region names 2 spaces. See https://www.drupal.org/node/2349827 for more information on defining a theme with an .info.yml file.

Also the link in your description is missing a closing tag.

You should also be quoting some of your strings. There is a link on the page above to read the quick introduction to the YAML file format that takes you to http://symfony.com/doc/current/components/yaml/yaml_format.html . That page provides good information on quoting strings.

2
  • I just came here because I had an error. But mine is not related to indentation but I omitted the content directive and placed other words since my site has many contents. Now, why does Drupal 8 show this error? Aren't site regions supposed to be arbitrary? – samayo Jun 28 '17 at 14:57
  • I believe they are except for one, which must be named content. I don't see this specifically mentioned on any of the Drupal API pages, but there is a check for it in api.drupal.org/api/drupal/… see // Require the 'content' region to make sure the main page // content has a common place in all themes. – rjl Jun 28 '17 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.