1

I am using Composer and Drush. Everything was working smoothly, but after I installed the Panels module with Composer, I started getting the following error all the times I run Drush.

Fatal error: Cannot redeclare composerRequireDrupal8() (previously declared in H:\wamp\www\www_d8test2_com\vendor\composer\autoload_real.php:63) in H:\wamp\www\www_d8test3_com\vendor\composer\autoload_real.php on line 70
Drush command terminated abnormally due to an unrecoverable error.
Error: Cannot redeclare composerRequireDrupal8() (previously declared in H:\wamp\www\www_d8test2_com\vendor\composer\autoload_real.php:63) in H:\wamp\www\www_d8test3_com\vendor\composer\autoload_real.php, line 70

Any help appreciated.

Please see what happened when I install panels module using composer:

Arun@HP MINGW64 /h/wamp/www/www_d8test3_com
$ composer require drupal/panels
Using version ^4.1 for drupal/panels
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 31 installs, 0 updates, 0 removals
  - Installing symfony/dom-crawler (v2.8.18): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing drupal/ctools (3.0.0): Downloading (failed)Downloading (100%)                                                                                                                    > Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing drupal/panels (4.1.0): Downloading (100%)
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing symfony/css-selector (v2.8.18): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing behat/mink (dev-master 9ea1ceb): Cloning 9ea1cebe3d from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing symfony/browser-kit (v2.8.18): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing fabpot/goutte (v3.2.1): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing behat/mink-browserkit-driver (v1.3.2): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing behat/mink-goutte-driver (v1.2.1): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing squizlabs/php_codesniffer (2.8.1): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing drupal/coder (8.2.12): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing jcalderonzumba/gastonjs (v1.0.2): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing jcalderonzumba/mink-phantomjs-driver (v0.3.1): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing mikey179/vfsstream (v1.6.4): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing sebastian/version (1.0.6): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing sebastian/global-state (1.1.1): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing sebastian/recursion-context (1.0.5): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing sebastian/exporter (1.2.2): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing sebastian/environment (1.3.8): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing sebastian/diff (1.4.1): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing sebastian/comparator (1.2.4): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing phpunit/php-text-template (1.2.1): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing doctrine/instantiator (1.0.5): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing phpunit/phpunit-mock-objects (2.3.8): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing phpunit/php-timer (1.0.9): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing phpunit/php-file-iterator (1.4.2): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing phpunit/php-token-stream (1.4.11): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing phpunit/php-code-coverage (2.2.4): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing phpdocumentor/reflection-docblock (2.0.4): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing phpspec/prophecy (v1.7.0): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
  - Installing phpunit/phpunit (4.8.35): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
behat/mink suggests installing behat/mink-selenium2-driver (slow, but JS-enabled                                                                                                                 driver for any app (requires Selenium2))
behat/mink suggests installing behat/mink-zombie-driver (fast and JS-enabled hea                                                                                                                dless driver for any app (requires node.js))
sebastian/global-state suggests installing ext-uopz (*)
phpunit/php-code-coverage suggests installing ext-xdebug (>=2.2.1)
phpdocumentor/reflection-docblock suggests installing dflydev/markdown (~1.0)
phpdocumentor/reflection-docblock suggests installing erusev/parsedown (~1.0)
phpunit/phpunit suggests installing phpunit/php-invoker (~1.1)
Writing lock file
Generating autoload files
> Drupal\Core\Composer\Composer::preAutoloadDump
> Drupal\Core\Composer\Composer::ensureHtaccess

Arun@HP MINGW64 /h/wamp/www/www_d8test3_com

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.