0

I pritty messed up my site by updating my 8.2.6 site as followed.

Step 1: I edit my composer.json file. I replaced the replace to require "replace": { "drupal/core": "~8.3" to

"require": { "drupal/core": "~8.3"

Because I wanted to update core and vendor I did this composer command step 2: composer update --with-dependencies

step 3: Site was broken unexpected error (500) using WAMP 2.4.23, php version 7.0.10 and mysql 5.7.14.

Do I have to update to 8.3.0 first before I can update to latest stable release? - example: composer require drupal/core:8.3.0

  • What is the error? – Kevin May 18 '17 at 17:06
  • unexpected error please try again later, when inspect with google console only get 500 error. Nothing specific – Joehoe May 18 '17 at 17:15
  • Need the actual error. – Kevin May 18 '17 at 17:15
  • Failed to load resource: the server responded with a status of 500 (500 Service unavailable – Joehoe May 18 '17 at 17:20
  • That's your browser/server's generic error message. Check your logs for the actual php error message – Clive May 18 '17 at 17:32
0

It depends on your modules. If you are using DisplaySuite there is an issue with updating because of the change from layout_plugin to the layout_discovery module. See this issue. And have a look at the 8.3.0 Release Notes for broken changes and affected modules.

  • Interesting, I think this is the problem, after reading this issue I think I can do 2 things. add patch (new to me) or 1)Suggestion, update all modules that use layout_plugin, panels,panelizer, ds 2) Do not run cache clear, go to extend and uninstall layout_plugin 3) After start uninstall upper error with layout_discovery, not found service.(But layout_plugin is uninstalled with success ) 4) drush en layout_discovery, update succes – Joehoe May 19 '17 at 15:38
  • But Ibefore start with the suggestion, I have to update 'drupal/core' first? – Joehoe May 19 '17 at 15:40
  • I updated the core first, then I've upgrated Display Suite to the new branch and at least I patched Display Suite. – RWAM May 19 '17 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.